ID: CVE-2022-40127

Last Modified: Nov. 16, 2022

A vulnerability in Example Dags of Apache Airflow allows an attacker with UI access who can trigger DAGs, to execute arbitrary commands via manually provided run_id parameter. This issue affects Apache Airflow Apache Airflow versions prior to 2.4.0.

Twitter Activity

Tweets last week: 40

Remaining steady

Yahoo Activity

Yahoo results: 5

Remaining steady

EPSS History

Current EPSS Score: 0.11752

Remaining steady


Reddit Activity

Reddit Posts: 1

Remaining steady

Github Repos

Github Repos: 1

Remaining steady

Exploits

Found exploits:

Attack Vector: Network

Attack Complexity: Low

Privileges Required: Low

User Interaction: None

Scope: Unchanged

Confidentiality: High

Integrity: High

Availability: High

Base Score: 8.8

Exploitability Score: 2.8

Impact Score: 5.9

CVSS V3: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Specialize CVSS-Score

CWE-94

Condition Configuration
OR
OR
Alle Schwachstellen für apache
Date: Nov. 14, 2022

Reference:
added:
http://www.openwall.com/lists/oss-security/2022/11/14/2



Date: Nov. 16, 2022

Base Score V3: Not defined
Exploitability Score V3: Not defined
Impact Score V3: Not defined
Cvss Vector V3: Not defined
Configuration:
added:
cpe:2.3:a:apache:airflow:*:*:*:*:*:*:*:*



                    <?xml version="1.0" ?>
<set operator="and">
    <set operator="or">
        <prop key="application" value="cpe:2.3:a:apache:airflow:*:*:*:*:*:*:*:*"/>
    </set>
</set>

                  
                      <?xml version="1.0" ?>
<set operator="and">
    <set operator="or">
        <prop key="application" value="cpe:2.3:a:apache:airflow:*:*:*:*:*:*:*:*"/>
    </set>
    <prop key="program_influence" value="input"/>
</set>